Croogo 2.1.0 Released

Posted by Rachman Chavik on Tue, Sep 02 2014

The Croogo Development Team is happy to announce the release of Croogo 2.1.0.  This release contains a security fix and all users are recommended to upgrade. Thanks to Gjoko Krstic from Zero Science Lab for the assist.

In terms of functionality, it contains a relatively invasive change on the way admin views are constructed, but otherwise should be backward compatible.  Please report any bugs in github.  You can also contribute to the documentation for this release in github.

Downloads

Croogo 2.1.0 can be downloaded from http://downloads.croogo.org/

2.1.0 Changelog

Following are some of the major changes since the last preview release:

  • Minimum CakePHP version 2.5.4
  • Themes can now use Config/theme.json to store settings (webroot/theme.json is still supported for backward compatibility)
  • Improvements on CroogoHtmlHelper and CroogoFormHelper
  • RegionsHelper::blocks() have been refactored adding RegionsHelper::block()
  • Admin view files have been greatly changed to utilize CakePHP view blocks.

For detailed changelog, please consult the commit history.

A huge thanks to Appsbender, Dimas Abdul Aziiz, Lukas Strassel, Paul Gardner, Rachman Chavik, Walther Lalk, Yuan Chavik, avra911, kareypowell, mohammadsaleh, roland-w, and stelioschar in contributing to both releases.

0 Comments